#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<item>([^<]+)</item>"
Local $sString = "<item>" & @CRLF & _
" foo bar foo bar " & @CRLF & _
" <item> child item </item>" & @CRLF & _
"</item>" & @CRLF & _
"<item>" & @CRLF & _
" second item" & @CRLF & _
" <item> second child </item>" & @CRLF & _
"</item>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")