using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<item>([^<]+)</item>";
string input = @"<item>
foo bar foo bar
<item> child item </item>
</item>
<item>
second item
<item> second child </item>
</item>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}