// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<item>([^<]+)</item>").unwrap();
let string = "<item>
foo bar foo bar
<item> child item </item>
</item>
<item>
second item
<item> second child </item>
</item>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}