package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<item>([^<]+)</item>`)
var str = `<item>
foo bar foo bar
<item> child item </item>
</item>
<item>
second item
<item> second child </item>
</item>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}