re = /<item>([^<]+)<\/item>/i
str = '<item>
foo bar foo bar
<item> child item </item>
</item>
<item>
second item
<item> second child </item>
</item>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end