import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<item>([^<]+)</item>";
final String string = "<item>\n"
+ " foo bar foo bar \n"
+ " <item> child item </item>\n"
+ "</item>\n"
+ "<item>\n"
+ " second item\n"
+ " <item> second child </item>\n"
+ "</item>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}