import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[(?:(?!\\[\\[|]]).)*\\]\\]|\\b(FOO)\\b";
final String string = "lorem ipsum FOO dolor\n"
+ "Should NOT match : lorem ipsum [[FOO]] dolor ==> OK\n"
+ "Should NOT match : lorem [[ipsum FOO dolor]] sit amet ==> Not OK\n"
+ "Should NOT match : lorem [[ipsumFOOsolor]] sit amet ==> OK\n"
+ "Should NOT match : [[lorem]] [[ipsum-FOO&dolor-sit.pdf#page=130]] ==> Not OK\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}