import re
regex = re.compile(r"\[\[(?:(?!\[\[|]]).)*\]\]|\b(FOO)\b", flags=re.MULTILINE)
test_str = ("lorem ipsum FOO dolor\n"
"Should NOT match : lorem ipsum [[FOO]] dolor ==> OK\n"
"Should NOT match : lorem [[ipsum FOO dolor]] sit amet ==> Not OK\n"
"Should NOT match : lorem [[ipsumFOOsolor]] sit amet ==> OK\n"
"Should NOT match : [[lorem]] [[ipsum-FOO&dolor-sit.pdf#page=130]] ==> Not OK\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")