#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[abcde].{5}$"
Local $sString = "345jj jdgjrf48 4954af94df" & @CRLF & _
"urj3/ksdjgjhd12345" & @CRLF & _
"kdfjck49k432elqepr" & @CRLF & _
"28234982345e123456" & @CRLF & _
"a12345" & @CRLF & _
"bb12345" & @CRLF & _
"';c.$&#$" & @CRLF & _
"ea " & @CRLF & _
"aaaaaa" & @CRLF & _
"aaaaaaa" & @CRLF & _
"abcdef" & @CRLF & _
"fffffff" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")