using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[abcde].{5}$";
string input = @"345jj jdgjrf48 4954af94df
urj3/ksdjgjhd12345
kdfjck49k432elqepr
28234982345e123456
a12345
bb12345
';c.$&#$
ea
aaaaaa
aaaaaaa
abcdef
fffffff
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}