// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[abcde].{5}$").unwrap();
let string = "345jj jdgjrf48 4954af94df
urj3/ksdjgjhd12345
kdfjck49k432elqepr
28234982345e123456
a12345
bb12345
';c.$&#$
ea
aaaaaa
aaaaaaa
abcdef
fffffff
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}