$re = '/[abcde].{5}$/m';
$str = '345jj jdgjrf48 4954af94df
urj3/ksdjgjhd12345
kdfjck49k432elqepr
28234982345e123456
a12345
bb12345
\';c.$&#$
ea
aaaaaa
aaaaaaa
abcdef
fffffff
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);