import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[abcde].{5}$";
final String string = "345jj jdgjrf48 4954af94df\n"
+ "urj3/ksdjgjhd12345\n"
+ "kdfjck49k432elqepr\n"
+ "28234982345e123456\n"
+ "a12345\n"
+ "bb12345\n"
+ "';c.$&#$\n"
+ "ea \n"
+ "aaaaaa\n"
+ "aaaaaaa\n"
+ "abcdef\n"
+ "fffffff\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}