package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[abcde].{5}$`)
var str = `345jj jdgjrf48 4954af94df
urj3/ksdjgjhd12345
kdfjck49k432elqepr
28234982345e123456
a12345
bb12345
';c.$&#$
ea
aaaaaa
aaaaaaa
abcdef
fffffff
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}