#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!http|$)"
Local $sString = "abc.com" & @CRLF & _
"http://abc.com" & @CRLF & _
"" & @CRLF & _
"https://foo.org" & @CRLF & _
""
Local $sSubst = "http://"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)