re = /^(?!http|$)/m
str = 'abc.com
http://abc.com
https://foo.org
'
subst = 'http://'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result