const regex = /^(?!http|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!http|$)', 'gm')
const str = `abc.com
http://abc.com
https://foo.org
`;
const subst = `http://`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);