use strict;
my $str = 'abc.com
http://abc.com
https://foo.org
';
my $regex = qr/^(?!http|$)/mp;
my $subst = 'http://';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";