import Foundation
let pattern = #"^(?!http|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc.com
http://abc.com
https://foo.org
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"http://"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)