$re = '/^(?!http|$)/m';
$str = 'abc.com
http://abc.com
https://foo.org
';
$subst = "http://";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;