#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<\!--(?!\[if).*?-->"
Local $sString = "<script type="text/javascript">" & @CRLF & _
" <!-- should stay" & @CRLF & _
" // wouldnt be touched" & @CRLF & _
" some_js_code();" & @CRLF & _
" //--> should stay" & @CRLF & _
"</script>" & @CRLF & _
"" & @CRLF & _
"<!--should be removed-->" & @CRLF & _
"" & @CRLF & _
"<!--" & @CRLF & _
"<should>" & @CRLF & _
"<be>" & @CRLF & _
"remved" & @CRLF & _
"</be>" & @CRLF & _
"</should>" & @CRLF & _
"-->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")