re = /<\!--(?!\[if).*?-->/
str = '<script type="text/javascript">
<!-- should stay
// wouldnt be touched
some_js_code();
//--> should stay
</script>
<!--should be removed-->
<!--
<should>
<be>
remved
</be>
</should>
-->'
# Print the match result
str.match(re) do |match|
puts match.to_s
end