using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\!--(?!\[if).*?-->";
string input = @"<script type=""text/javascript"">
<!-- should stay
// wouldnt be touched
some_js_code();
//--> should stay
</script>
<!--should be removed-->
<!--
<should>
<be>
remved
</be>
</should>
-->";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}