const regex = /<\!--(?!\[if).*?-->/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\!--(?!\\[if).*?-->', 's')
const str = `<script type="text/javascript">
<!-- should stay
// wouldnt be touched
some_js_code();
//--> should stay
</script>
<!--should be removed-->
<!--
<should>
<be>
remved
</be>
</should>
-->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}