$re = '/<\!--(?!\[if).*?-->/s';
$str = '<script type="text/javascript">
<!-- should stay
// wouldnt be touched
some_js_code();
//--> should stay
</script>
<!--should be removed-->
<!--
<should>
<be>
remved
</be>
</should>
-->';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);