import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\!--(?!\\[if).*?-->";
final String string = "<script type=\"text/javascript\">\n"
+ " <!-- should stay\n"
+ " // wouldnt be touched\n"
+ " some_js_code();\n"
+ " //--> should stay\n"
+ "</script>\n\n"
+ "<!--should be removed-->\n\n"
+ "<!--\n"
+ "<should>\n"
+ "<be>\n"
+ "remved\n"
+ "</be>\n"
+ "</should>\n"
+ "-->";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}