# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)\.(?=\d)/,/gm;t' <<< "<p>23.5</p>
Hello Mr. John <p>23.5</p> Hello World
Hello Mr. John <p>23.5</p> Hello World 12.23
"