use strict;
my $str = '<p>23.5</p>
Hello Mr. John <p>23.5</p> Hello World
Hello Mr. John <p>23.5</p> Hello World 12.23
';
my $regex = qr/(?<=\d)\.(?=\d)/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";