#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\d)\.(?=\d)"
Local $sString = "<p>23.5</p>" & @CRLF & _
"Hello Mr. John <p>23.5</p> Hello World" & @CRLF & _
"Hello Mr. John <p>23.5</p> Hello World 12.23" & @CRLF & _
""
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)