import Foundation
let pattern = #"(?<=\d)\.(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p>23.5</p>
Hello Mr. John <p>23.5</p> Hello World
Hello Mr. John <p>23.5</p> Hello World 12.23
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)