$re = '/(?<=\d)\.(?=\d)/m';
$str = '<p>23.5</p>
Hello Mr. John <p>23.5</p> Hello World
Hello Mr. John <p>23.5</p> Hello World 12.23
';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;