const regex = /(?<=\d)\.(?=\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)\\.(?=\\d)', 'gm')
const str = `<p>23.5</p>
Hello Mr. John <p>23.5</p> Hello World
Hello Mr. John <p>23.5</p> Hello World 12.23
`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);