# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\r\n]^([^"])/$1/gm;t' <<< "header1|header2|header3
\"ID001\"|\"\"\"TEST\"\"\"|\"
TEST TEST TEST\"|\"TEST 4\"
\"ID002\"|\"TEST\"|\"TESTTESTTEST\"|\"TEST 5\""