package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\r\n]^([^"])`)
var str = `header1|header2|header3
"ID001"|"""TEST"""|"
TEST TEST TEST"|"TEST 4"
"ID002"|"TEST"|"TESTTESTTEST"|"TEST 5"`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}