// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[\r\n]^([^"])"#).unwrap();
let string = "header1|header2|header3
\"ID001\"|\"\"\"TEST\"\"\"|\"
TEST TEST TEST\"|\"TEST 4\"
\"ID002\"|\"TEST\"|\"TESTTESTTEST\"|\"TEST 5\"";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}