using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\r\n]^([^""])";
string substitution = @"$1";
string input = @"header1|header2|header3
""ID001""|""""TEST""""|""
TEST TEST TEST""|""TEST 4""
""ID002""|""TEST""|""TESTTESTTEST""|""TEST 5""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}