#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[\r\n]^([^"])"
Local $sString = "header1|header2|header3" & @CRLF & _
""ID001"|"""TEST"""|"" & @CRLF & _
"TEST TEST TEST"|"TEST 4"" & @CRLF & _
""ID002"|"TEST"|"TESTTESTTEST"|"TEST 5""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)