const regex = /[\r\n]^([^"])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\r\\n]^([^"])', 'gm')
const str = `header1|header2|header3
"ID001"|"""TEST"""|"
TEST TEST TEST"|"TEST 4"
"ID002"|"TEST"|"TESTTESTTEST"|"TEST 5"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);