#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:https?:\/\/\S+)?\S+\.\S+\.?\S+"
Local $sString = "test http://www.espn.com was great" & @CRLF & _
"test espn.com was great" & @CRLF & _
"test http://espn.com was great" & @CRLF & _
"test www.espn.com was great" & @CRLF & _
"test https://www.espn.com was great" & @CRLF & _
"test https://www.espn.com/?q=soccer was great"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")