re = /(?:https?:\/\/\S+)?\S+\.\S+\.?\S+/
str = 'test http://www.espn.com was great
test espn.com was great
test http://espn.com was great
test www.espn.com was great
test https://www.espn.com was great
test https://www.espn.com/?q=soccer was great'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end