$re = '/(?:https?:\/\/\S+)?\S+\.\S+\.?\S+/';
$str = 'test http://www.espn.com was great
test espn.com was great
test http://espn.com was great
test www.espn.com was great
test https://www.espn.com was great
test https://www.espn.com/?q=soccer was great';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);