using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/\S+)?\S+\.\S+\.?\S+";
string input = @"test http://www.espn.com was great
test espn.com was great
test http://espn.com was great
test www.espn.com was great
test https://www.espn.com was great
test https://www.espn.com/?q=soccer was great";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}