package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:https?:\/\/\S+)?\S+\.\S+\.?\S+`)
var str = `test http://www.espn.com was great
test espn.com was great
test http://espn.com was great
test www.espn.com was great
test https://www.espn.com was great
test https://www.espn.com/?q=soccer was great`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}