import Foundation
let pattern = #"(?:https?:\/\/\S+)?\S+\.\S+\.?\S+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
test http://www.espn.com was great
test espn.com was great
test http://espn.com was great
test www.espn.com was great
test https://www.espn.com was great
test https://www.espn.com/?q=soccer was great
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)