import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(\\d+\\.?|\\.\\d+)\\d?(e-?\\d+)?$";
final String string = "0\n"
+ "true\n\n"
+ "0.1\n"
+ "true\n\n"
+ "abc\n"
+ "false\n\n"
+ "1 a\n"
+ "false\n\n"
+ "2e10\n"
+ "true\n\n"
+ "-90e3\n"
+ "true\n\n"
+ "1e\n"
+ "false\n\n"
+ "e3\n"
+ "false\n\n"
+ "6e-1\n"
+ "true\n\n"
+ "99e2.5\n"
+ "false\n\n"
+ "53.5e93\n"
+ "true\n\n"
+ "--6\n"
+ "false\n\n"
+ "-+3\n"
+ "false\n\n"
+ "95a54e53\n"
+ "false\n\n"
+ ".\n"
+ "false";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}