re = /^-?(\d+\.?|\.\d+)\d?(e-?\d+)?$/m
str = '0
true
0.1
true
abc
false
1 a
false
2e10
true
-90e3
true
1e
false
e3
false
6e-1
true
99e2.5
false
53.5e93
true
--6
false
-+3
false
95a54e53
false
.
false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end