// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?(\d+\.?|\.\d+)\d?(e-?\d+)?$").unwrap();
let string = "0
true
0.1
true
abc
false
1 a
false
2e10
true
-90e3
true
1e
false
e3
false
6e-1
true
99e2.5
false
53.5e93
true
--6
false
-+3
false
95a54e53
false
.
false";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}