import re
regex = re.compile(r"^-?(\d+\.?|\.\d+)\d?(e-?\d+)?$", flags=re.MULTILINE)
test_str = ("0\n"
"true\n\n"
"0.1\n"
"true\n\n"
"abc\n"
"false\n\n"
"1 a\n"
"false\n\n"
"2e10\n"
"true\n\n"
"-90e3\n"
"true\n\n"
"1e\n"
"false\n\n"
"e3\n"
"false\n\n"
"6e-1\n"
"true\n\n"
"99e2.5\n"
"false\n\n"
"53.5e93\n"
"true\n\n"
"--6\n"
"false\n\n"
"-+3\n"
"false\n\n"
"95a54e53\n"
"false\n\n"
".\n"
"false")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")