use strict;
my $str = '0
true
0.1
true
abc
false
1 a
false
2e10
true
-90e3
true
1e
false
e3
false
6e-1
true
99e2.5
false
53.5e93
true
--6
false
-+3
false
95a54e53
false
.
false';
my $regex = qr/^-?(\d+\.?|\.\d+)\d?(e-?\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}