# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\"claim1\":)(.*?)\"(.*?)\"/$3/gm;t' <<< "{ \"claim1\": \"val1\", \"claim2\": \"val2\" }"